PostNL incident Shippingstatus: resolved

Incident Report for PostNL

Resolved

Our technical team identified the root cause of the incident. The necessary fix has been successfully implemented, and normal service has been restored. We recommend verifying that you can access and use the service as expected. If you encounter any persisting issues or have concerns, please report them promptly to our support team at Need help? Contact us | PostNL
Posted Aug 06, 2025 - 14:45 CEST

Investigating

The incident is currently under investigation by our technical team. We are actively working to identify and resolve the issue to restore normal service as quickly as possible.
Posted Aug 06, 2025 - 14:30 CEST
This incident affected: Send & Track (Shippingstatus).