Scheduled for July 30, 2024 at 7:00 AM – 8:00 AM
Completed
July 30, 2024 at 8:00 AMCompleted
July 30, 2024 at 8:00 AMMaintenance has completed successfully
In progress
July 30, 2024 at 7:00 AMIn progress
July 30, 2024 at 7:00 AMMaintenance is now in progress
Planned
July 30, 2024 at 7:00 AMPlanned
July 30, 2024 at 7:00 AMOn the 30th of July, there will be scheduled maintenance on the backend. No downtime is expected.